Genesys Discussion Forum



Go Back   Genesys Discussion Forum > Technical Discussions > Workforce Management (WFM)

Workforce Management (WFM) A comprehensive workforce performance management application

Reply
 
Thread Tools Display Modes
  #1  
Old 12-15-2010, 01:29 AM
Genesys_user Genesys_user is offline
Member
Hero
 
Join Date: Sep 2009
Posts: 33
Genesys_user is an unknown quantity at this point
Default WFM Server Error

Hi,

I have installed WFM 8. When WFM Server service is started I see the following errors in the log:

************************************
12/15/10 15:43:13.609 CFSLCache: Cache loaded successfully.
15:43:13.609 Trc 20001 Genesys WFM Server Version: 8.0.001.03 Compiled: Sep 20 2010 13:33:54
Copyright (c) 1999-2004 by Genesys Telecommunications Laboratories, Inc. All Rights Reserved.

12/15/10 15:43:13.609 Initializing...
12/15/10 15:43:13.687 Config Cache Preload -- Start (Cache Size: 0Kb, Target Size: 20Mb, Thread: 5132)
15:43:13.734 Std 20000 Could not open database Provider=SQLOLEDB;Data Source=SRVABC;Initial Catalog=WFM_DB;User ID=sa; reason -- ; error code -2147221164 (Thread: 5132)
12/15/10 15:43:13.734 Config Cache Preload -- End (Cache Size: 0Kb, Thread: 5132)
12/15/10 15:43:13.859 Schedule Cache Preload -- Start (Cache Size: 0Kb, Target Size: 20Mb, Thread: 4924)
15:43:13.859 Std 20000 Could not open database Provider=SQLOLEDB;Data Source=SRVABC;Initial Catalog=WFM_DB;User ID=sa; reason -- ; error code -2147221164 (Thread: 4924)
12/15/10 15:43:13.859 Schedule Cache Preload -- End (Cache Size: 0Kb, Thread: 4924)
15:43:13.859 Trc 04003 WFM_SERVER main process started
15:43:13.859 Std 04525 Port 6210 opened for listening
************************************

Troubleshooting actions:
I had set auto_close to off for the database.

alter database WorkForceManagement set auto_close off;

I am using SQL Server 2000. I tried using another database as well but I am still facing the same issue. Can anyone please help me resolve the same?

Thanks,
Genesys_user
Reply With Quote
  #2  
Old 12-15-2010, 08:46 AM
Leon's Avatar
Leon Leon is offline
Member
Power Poster
 
Join Date: Feb 2009
Posts: 69
Leon is an unknown quantity at this point
Default

Hi

Can you connect to the WFM database using either the WFM Configuration Utility or WFM Database Utility?
Reply With Quote
  #3  
Old 12-15-2010, 11:02 PM
Genesys_user Genesys_user is offline
Member
Hero
 
Join Date: Sep 2009
Posts: 33
Genesys_user is an unknown quantity at this point
Default

Hi Leon,

Yes, I am able to connect the database via WFM Configuration Utility and WFM Database Utility. Infact tables have been successfully created by WFM Database Utility.

I did observe the following errors in Data Aggregator log:
************************************
12/15/10 17:42:35.703 CFGRegistered
12/15/10 17:42:35.703 CFGEndObjectList, Object Type: 9, ReqID: 21
12/15/10 17:42:35.734 CFGEndObjectList, Object Type: 10, ReqID: 22
12/15/10 17:42:35.765 CFGEndObjectList, Object Type: 9, ReqID: 23
12/15/10 17:42:35.781 CFGEndObjectList, Object Type: 9, ReqID: 24
12/15/10 17:42:35.812 CFGEndObjectList, Object Type: 9, ReqID: 25
12/15/10 17:42:35.828 CFSLCache: Cache loaded successfully.
12/15/10 17:42:35.875 CFGEndObjectList, Object Type: 9, ReqID: 26
12/15/10 17:42:35.906 CFGEndObjectList, Object Type: 9, ReqID: 27
17:42:35.921 Trc 25146 DB_INFO: Thread 'Main'(1) is connecting to the database. DBType='mssql', Host='SRVABC', DBName='WFM_DB', User='sa'.
17:42:35.984 Std 25122 DB_ERROR: Thread 'Main'(1) failed to connect to database due to COM exception. HR=-2147221164, MSG='Class not registered' Descr='(null)'.
17:42:35.984 Trc 25099 DB_CONFIG_INFO: Thread 'Main'(1) db connection params. DBType='mssql', Host='SRVABC', DBName='WFM_DB', User='sa'.
12/15/10 17:42:37.000 CFGEndObjectList, Object Type: 9, ReqID: 28
17:42:37.015 Trc 25146 DB_INFO: Thread 'Main'(2) is connecting to the database. DBType='mssql', Host='SRVABC', DBName='WFM_DB', User='sa'.
17:42:37.015 Std 25122 DB_ERROR: Thread 'Main'(2) failed to connect to database due to COM exception. HR=-2147221164, MSG='Class not registered' Descr='(null)'.
17:42:37.015 Trc 25099 DB_CONFIG_INFO: Thread 'Main'(2) db connection params. DBType='mssql', Host='SRVABC', DBName='WFM_DB', User='sa'.
12/15/10 17:42:38.031 CFGEndObjectList, Object Type: 9, ReqID: 29
************************************

I am not sure where the issue is.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
T-server Event Error - Errorcode Description sharavshiva Interaction SDK 5 10-19-2010 08:15 AM
Error in Interaction Server 7.6.1.x bounty eServices 1 07-01-2010 11:57 PM
Error while Switchover to Primary Server mhsrinivasan Platform SDK 3 07-07-2009 07:09 PM
Web Service error :0013 Remote Server Error Manas Inbound Voice 3 06-22-2009 12:25 PM
Error when trying to send requests through interaction server to OCS jbrooks Platform SDK 1 04-08-2009 01:40 PM

Copyright 2008 - 2009, Genesys Telecommunications Laboratories, Inc.

Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
All Rights Reserved